Mi nombre es Fernando Briano y soy programador.

Iceweasel 3.5.2 en Debian Squeeze con Experimental

Iceweasel

Iceweasel

Actualmente Iceweasel todavía no ha pegado el salto importante al código de Firefox 3.5, versión actualizada y con muchos cambios (tags html5 para audio y video, entre otros). En las versiones estable, testing e inestable, todavía debemos instalar la versión 3.0: lenny : 3.0.6-1,  squeeze y sid: 3.0.12-13.0.12-1

Iceweasel es un fork de Firefox hecho por Debian con dos objetivos principales:

  1. Backporting de arreglos de seguridad para la versión declarada Debian estable.
  2. No incluir el arte registrado de Mozilla (debido al #1)

Aparte de eso, Iceweasel es básicamente idéntico a Mozilla Firefox.

Aunque no haya llegado al repositorio en Squeeze, podemos instalar la versión 3.5.2 desde el repositorio experimental. Para esto, hay que editar el archivo /etc/apt/sources.list y cambiar el repositorio que tengamos: lenny, squeeze (mi caso), o sid. por experimental. También podemos agregar directamente la línea experimental que puede coexistir con nuestro repositorio común, ya que no se instalan paquetes experimentales por defecto:

  deb http://ftp.debian.org/debian experimental main

Para seguir con la instalación de Iceweasel:

apt-get update
apt-get -t experimental install iceweasel

El mismo parámetro (“-t experimental”) es necesario para instalar cualquier paquete desde experimental.

Recuerden que el repositorio experimental no alberga una distribución completa de Debian como inestable o testing, por lo que pueden haber inconsistencias en dependencias. Así que fíjense bien los paquetes que decidan instalar desde experimental antes de probar.

En mi caso solamente se instalaron libmozjs2d y xulrunner-1.9.1 como paquetes nuevos,  y se actualizó Iceweasel a la versión más nueva.

Iceweasel 3.5.2 Debian Squeeze

Iceweasel 3.5.2 Debian Squeeze

Recuerden si quieren seguir usando sus plugins de Firefox, entrar al about:config, y agregar dos valor booleanos con valor false: extensions.checkCompatibility y extensions.checkUpdateSecurity para que no se chequee la compatibilidad. Hay que tener cuidado con esto, ya que algunos plugins pueden no funcionar correctamente, en algunos casos incluso dar una violación de segmento, ya que no han sido actualizados a la versión más reciente de Firefox.

Pueden ir siguiendo el desarrollo de Iceweasel en: http://packages.qa.debian.org/i/iceweasel.html

Feed de comentarios | Url para Trackbacks | Suscribirse a los posts por correo electrónico

5 comentarios en este post

  1. Avatar Dark Musician 3 Septiembre. 2009 - 10:40 am Safari 530.17 Windows XP

    Qué pereza los posts sobre instalar navegadores en linux y cosillas por el estilo.

  2. Avatar fernando 3 Septiembre. 2009 - 10:56 am GNU IceCat 3.5.2 GNU/Linux 64 bits

    Jeje, sí. Prometo posts más “sustanciosos” ni bien tenga algo de tiempo. No publicaré más sobre navegadores por un tiempo 😛

    Parece que tuviera una obsesión… En este momento estoy ejecutando: Iceweasel, Icecat, Google Chrome, Chromium y Opera 😛

  3. Avatar Arlequín 3 Septiembre. 2009 - 12:30 pm Firefox 3.5.2 Windows NT

    Hola, Fernando.

    También me funcionó en mi Debian Unstable con:

    # aptitude install iceweasel=3.5.2-1

    Claro, con el repo experimental habilitado.

  4. Avatar Carlos 24 Septiembre. 2009 - 5:12 pm Opera 9.80 GNU/Linux

    Interesante entrada muchas gracias. Con el splash de la pagina web de iceweasel no me funcionaba

  1. StatusNet Fernando (fbt) 's status on Thursday, 03-Sep-09 12:09:58 UTC - Identi.ca | 3 Septiembre. 2009 - 10:10 am

Dejar un comentario

Toasty!