Mi nombre es Fernando Briano y soy programador.

¡Disponible GNU IceCat 3.5!

GNU IceCat

GNU IceCat

Giuseppe Scrivano anunció la disponibilidad de GNU IceCat, el navegador web basado en el código fuente de Mozilla Firefox, pero totalmente libre. Esta versión incluye las mejoras de Firefox 3.5, y está disponible en:

ftp://ftp.gnu.org/gnu/gnuzilla/3.5/

Pueden ver una lista de mirrors en:

http://www.gnu.org/order/ftp.html

Es una buena noticia para usuarios de Debian que no contamos todavía con lo nuevo de Firefox 3.5 en Iceweasel (3.0.9-1 en squeeze y 3.0.11-1 en sid todavía…).

En mi caso soy medio fanático, y uso tanto Iceweasel como Arora, Icecat, y en algunos casos incluso Flock 😛
Recientemente estoy probando también Google Chrome en su versión de desarrollo para sistemas GNU/Linux.

Una de las cosas “raras” de esta nueva versión de GNU Icecat, es que utiliza el plugin privativo de Flash. Si entramos en about:plugins, podemos leer la siguiente información:

Shockwave Flash

File name: libflashplayer.so
Shockwave Flash 10.0 r22
MIME TypeDescriptionSuffixesEnabled
application/x-shockwave-flashShockwave FlashswfYes
application/futuresplashFutureSplash PlayersplYes

Esta pc está formateada de hace poco tiempo, y no tenía instalado el plugin de Gnash, el cual permite instalar IceCat, pero sí tenía Flash en Iceweasel. Y de alguna manera, Icecat obtuvo el plugin también. Me suena raro, veremos…

UPDATE:
Le pregunté en Identi.ca a Giuseppe Scrivano respecto al plugin privativo de Flash. Y respondió:

@fbt, es porque tienes instalados plugins privativos en tu máquina. IceCat usa plugins instalados globalmente, es una característica, no un error

Aparentemente esto es una característica agregada a partir de la nueva versión, ya que no era así en versiones anteriores. En fin, ahora cada uno se hace responsable de lo que instala en su máquina 😛
De todas formas, no me termina de convencer que permita el uso de software privativo, si era la idea inicial del proyecto.

Algunas de las extensiones de uso general que tenía instaladas no son compatibles (en teoría) con Icecat 3.5. Esto se puede evitar, y usarlas de todos modos como ya había comentado de la siguiente manera:

Entrar al about:config, y agregar dos valor booleanos con valor false: extensions.checkCompatibility y extensions.checkUpdateSecurity

Lo que hacen éstos valores es chequear la compatibilidad de las extensiones con la versión de Firefox que estemos usando, chequear actualizaciones de seguridad. Con el valor false le estamos diciendo que no lo chequee, use at your own risk…

En fin, muy bueno el trabajo de GNUzilla trayendo esta versión tan actualizada de Icecat.

GNU Icecat 3.5 en Debian

GNU Icecat 3.5 en Debian

Feed de comentarios | Url para Trackbacks | Suscribirse a los posts por correo electrónico

9 comentarios en este post

  1. Avatar Alejandro Segovia 16 julio. 2009 - 2:09 pm Safari 530.19 Mac OS

    Eso es algo que no me termina de cerrar del todo… GNUzilla hace un fork de firefox porque EL LOGO tiene copyright, pero no tienen problema en usar el plugin privativo de Flash??

    Estoy confundido o hay un doble criterio aqui?

  2. Avatar fernando 16 julio. 2009 - 3:39 pm GNU IceCat 3.5 Debian GNU/Linux

    Es que parte de la ‘idea’ de GNU IceCat es que no se puedan instalar plugins privativos. Seguramente sea algo con el código de Firefox 3.5, que busca el plugin automáticamente, o vendrá por el lado del tema de incluir soporte para video… no sé realmente.

    Pero sí, es como un doble criterio, no debería usar el plugin privativo de Flash, y debería recomendar Gnash como venía haciendo, y como tanto insiste la FSF.

  3. Avatar fernando 16 julio. 2009 - 5:27 pm GNU IceCat 3.5 Debian GNU/Linux

    Ahí actualicé la entrada con lo que me respondió el desarrollador de IceCat respecto al plugin privativo de Flash.

  4. Avatar Omar Botta 23 julio. 2009 - 1:07 pm GNU IceCat 3.5.1 GNU/Linux

    Ya lanzaron el 3.5.1 😀

    ftp://ftp.gnu.org/gnu/gnuzilla/3.5.1/

  5. Avatar Adolf 28 julio. 2009 - 12:47 am Firefox 3.0.10 Linux Mint

    Y yo sigo meta Firefox… para mí pocas cosas se le arriman, por el momento; Chrome es una.

    ¡Saludos!

  6. Avatar fernando 29 julio. 2009 - 9:10 pm GNU IceCat 3.5.1 GNU/Linux

    Actualizado a 3.5.1 😛

  7. Avatar fernando 31 mayo. 2010 - 11:15 pm GNU IceCat 3.6.3 GNU/Linux

    usa adobe flash porque gnash es realmente una porqueria ,,, n o le queda otra a icecat

  1. StatusNet Fernando (fbt) 's status on Tuesday, 14-Jul-09 06:11:17 UTC - Identi.ca | 14 julio. 2009 - 4:11 am

    […] ¡Disponible !GNU !Icecat 3.5! http://picandocodigo.net/2009/%c2%a1disponible-gnu-icecat-3-5/ […]

  2. Unknown Twitted by picandocodigo | 14 julio. 2009 - 4:15 am

    […] This post was Twitted by picandocodigo […]

Dejar un comentario

Toasty!